Installation de SMI et problème sur PHPNET

Installation, utilisation, paramétrage de SMI sous Gnu/Linux
Répondre
Tony
Nouveau membre
Messages : 5
Enregistré le : jeu. oct. 04, 2018 11:25 am

Installation de SMI et problème sur PHPNET

Message par Tony »

Bonjour,

J’ai essayé d’installer votre solution et à chaque fois que j’essaie d’importer la base de donnée de SMI en vers 1.0.6 dans phpmyadmin de Wamp ou sur mon compte online de PHPNET.org j’ai une erreur.

Je vais dans SMI / Install / SQL et j’essaie d’importer ce fichier : smi_1.0.6.sql
Sur phpnet j’ai cela :
Image

Et sur wamp j’ai :
Image

Une idée ?
Merci

Tony
Nouveau membre
Messages : 5
Enregistré le : jeu. oct. 04, 2018 11:25 am

Re: Installation de SMI et problème sur PHPNET

Message par Tony »

Aucune idée ?
Merci

serge.mata
Nouveau membre
Messages : 4
Enregistré le : ven. avr. 06, 2018 2:05 pm

Re: Installation de SMI et problème sur PHPNET

Message par serge.mata »

j'ai rencontrée le même problème .La seule solution que je puisse vous proposer est d'abord d'installée la base 1.0.4 (dans mon exemple smi est la base de donnée)
mysqladmin -u root -p create smi
mysql -u root -p smi < /var/www/html/smi/install/sql/smi_1.0.4.sql;
mysql -u root -p smi < /var/www/html/smi/install/sql/smi_1.0.4_to_1.0.5.sql;
mysql -u root -p smi < /var/www/html/smi/install/sql/smi_1.0.5_to_1.0.6.sql;
Cela a fonctionné pour moi
Ceci étant Wamp n''est pas une solution linux :D

Tony
Nouveau membre
Messages : 5
Enregistré le : jeu. oct. 04, 2018 11:25 am

Re: Installation de SMI et problème sur PHPNET

Message par Tony »

Oui je sais bien, sauf que je voulais déjà essayer de l'installer en local pour voir comment cela fonctionne.
J'ai fait comme vous avez dit. Effectivement je n'ai plus de problème de DB maintenant.
J'ai remplis mon fichier avec les paramètres.

J'appelle la page localhost/smi

et là j'ai cette erreur :
Fatal Error: ezSQL_mysql requires mySQL Lib to be compiled and or linked in to the PHP engine
Est-ce que cela vous parle ?

C'est dommage car ce script a l'air très bien mais l'installation ...
C'est compliqué pour les gens qui ne sont pas pro.

serge.mata
Nouveau membre
Messages : 4
Enregistré le : ven. avr. 06, 2018 2:05 pm

Re: Installation de SMI et problème sur PHPNET

Message par serge.mata »

Quelle est la version du Php et MySql ?

SMI ne fonctionne que Php 5.6 et Mysql 5.5

le connecteur MySql est-il installé ? Sous Linux cela peut être php5-mysql par exemple

Tony
Nouveau membre
Messages : 5
Enregistré le : jeu. oct. 04, 2018 11:25 am

Re: Installation de SMI et problème sur PHPNET

Message par Tony »

Bonjour,
Smi ne fonctionne QUE sur PHP5.6 et Mysql 5.5 ?

Merci

Tony
Nouveau membre
Messages : 5
Enregistré le : jeu. oct. 04, 2018 11:25 am

Re: Installation de SMI et problème sur PHPNET

Message par Tony »

Voici ma confiance sur phpnet

Les serveurs SQL mutualisé sont sur Maria DB 10.2.30 & utilise la version 7.0 de php.
Concernant les sites vous pouvez configurer jusqu'à la version php 7.4

Répondre