[RESOLU]Problème sur les paramètres

Vous avez détecté un bug ? Signalez-le ici.
Répondre
speader
Membre
Messages : 13
Enregistré le : lun. févr. 07, 2011 11:31 am

[RESOLU]Problème sur les paramètres

Message par speader »

Bonjour,

Je vient de redéployer la solution SMI sur un de mes serveurs dédiée chez OVH et lorsque je veux supprimer une fiche clients par exemples j'ai un message d'erreur "probleme sur les paramètre" mais quels paramètres ?!

Si quelqu'un à une solution je suis preneur.

Merci,
Modifié en dernier par speader le sam. janv. 07, 2012 9:19 am, modifié 1 fois.

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème sur les paramètres

Message par Galawa »

Bonjour,

Il faudrait voir les droits sur le dossier de stockage des fichiers techniques et clients.

Merci

Galawa
Gestionnaire du projet SMI

speader
Membre
Messages : 13
Enregistré le : lun. févr. 07, 2011 11:31 am

Re: Problème sur les paramètres

Message par speader »

Bonjour Galawa,

J'ai vérifié les droits, mais le plus étonnants c'est qu'ils sont verrouillés sur 755 et je ne peut pas les modifiés sur 777 et j'ai une erreur "problème sur les paramètres à la création et à la suppression des clients.

Cependant j'ai ouvert le répèrtoire /httpdocs/telechgt/fictec/clients et les dossiers ont été crées...

Je reste un peut perplexe.

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème sur les paramètres

Message par Galawa »

Bonjour,

Mettre des droit à 0777 sur un serveur de production, c'est "limite".

Quand je parle de droits, je parle du propriétaire des dossiers.

En effet, le script doit avoir le droit de créer ou de supprimer des dossiers, donc y avoir accès.

Je m'étais mal exprimé...désolé.

Galawa
Gestionnaire du projet SMI

speader
Membre
Messages : 13
Enregistré le : lun. févr. 07, 2011 11:31 am

Re: Problème sur les paramètres

Message par speader »

J'ai vérifié les droits et remis sur tes conseils à 755 mais a priori le script possède bien les droits étant données qu'il arrive à crée le répertoire avec le numéro client.

Là ou j'ai un doute c'est peut être au niveau de la base sql mais pourtant la table est bien en "grant" je ne devrais donc pas avoir de soucis d'écriture.

si je t'envoi en mp les accès tu peut jeter un oeil ? stp

Merci,

speader
Membre
Messages : 13
Enregistré le : lun. févr. 07, 2011 11:31 am

Re: Problème sur les paramètres

Message par speader »

Re,

Problème résolu, si jamais cela peut aider...

Alors en fait lors de la création des répertoires, par le script, tels que import ou pj etc.... étaient crée par l'utilisateur apache et non l'utilisateur (propriétaire) donc le groupe n'étant pas les mêmes la modification des droits et l'accès aux ressources est impossibles.

Donc pour ceux qui ont se problème il faut se connecter en root avec kitty ou autres, et modifiées le groupe d'apache faut juste faire gaffe car la sécurité est moins forte.

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème sur les paramètres

Message par Galawa »

Bonjour,

Le problème est apparu sous quelle distribution Linux ?

Merci

Sylvain
Gestionnaire du projet SMI

speader
Membre
Messages : 13
Enregistré le : lun. févr. 07, 2011 11:31 am

Re: Problème sur les paramètres

Message par speader »

Bonjour,

Plesk de chez Parallele...

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème sur les paramètres

Message par Galawa »

Plesk est une interface d'administration, pas une distribution.
Gestionnaire du projet SMI

speader
Membre
Messages : 13
Enregistré le : lun. févr. 07, 2011 11:31 am

Re: Problème sur les paramètres

Message par speader »

La distrib était RedHat mais c'est plesk qui va gérer les différents groupe et notamment les droits se qui explique se petit souci.

SP

Répondre