Impossible de clore une intervention

Vous avez détecté un bug ? Signalez-le ici.
feracheval
Membre
Messages : 77
Enregistré le : dim. févr. 15, 2009 10:40 pm

Impossible de clore une intervention

Message par feracheval »

Je n'arrive pas a clore une intervention car à chaque fois que je rentre la date de cloture on me dit :
"vous devez saisir un detail horaire et les techniciens traitants" et pourtant ils sont crées mais n'aparaissent pas dans la fenetre quand je clique "quiter" sur la fenetre "detail horaire".
Par contre si je clique dans l'espace techniciens traitant, la fenetre "detail horaire" s'ouvre déja renseignée !?
merci pour votre aide

feracheval
Membre
Messages : 77
Enregistré le : dim. févr. 15, 2009 10:40 pm

Message par feracheval »

en fait il faut une fois le detail horaire rempli, sortir carrement du client puis y revenir pour voir les champs remplis et cloturer le depannage.
Pas trés pratique, surement un petit bug...

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Bonjour,

Je viens de tester : aucun problème, tant en ajout de détail horaire qu'en modification ou suppression.

Les zones "Technicien(s) traitant(s)", "Temps travaillé", et le prix de revient se mettent bien à jour.

Javascript est bien activé ?

Merci
Gestionnaire du projet SMI

feracheval
Membre
Messages : 77
Enregistré le : dim. févr. 15, 2009 10:40 pm

Message par feracheval »

biensur, j'ai testé sur un autre pc et c'est idem.
Un autre exemple,
pour la tva, la case se met à jour uniquement si on ressort de la page et on revient ... :?

andromede88
Membre
Messages : 24
Enregistré le : ven. févr. 27, 2009 11:57 am

Message par andromede88 »

J'ai également le même probléme, les zones "Technicien(s) traitant(s)", "Temps travaillé", et le prix de revient ne se mettent pas à jour automatiquement.

Je suis obliger soit de quitter en enregistrant soit de faire F5 pour actualiser la fiche.

Sinon pas moyen de cloturer la fiche, cela fait pareil sur l'espace de test de t'on site Galawa.

feracheval
Membre
Messages : 77
Enregistré le : dim. févr. 15, 2009 10:40 pm

Message par feracheval »

ahh, on veut jamais me croire... :D
pour info, window vista et IE 7

andromede88
Membre
Messages : 24
Enregistré le : ven. févr. 27, 2009 11:57 am

Message par andromede88 »

Le fait que notre ami feracheval soit également sous IE 7 m'a mis sur la bonne voie.

J'ai refait le test sous Firefox et au miracle tous fonctionne....

Y a bien un bug mais c'est IE le bug !!!!!

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Bon...on va encore vérifier et devoir tester si IE fait (encore) des siennes.

C'est désespérant de voir à quel point le leader du marché se fiche des standards W3C... :(

Ca occasionne pas mal de travail tout ça, mais bon...
Gestionnaire du projet SMI

feracheval
Membre
Messages : 77
Enregistré le : dim. févr. 15, 2009 10:40 pm

Message par feracheval »

:cry: désolé, bon courage on attend la réponse, je met en standby le projet en attentant...

andromede88
Membre
Messages : 24
Enregistré le : ven. févr. 27, 2009 11:57 am

Message par andromede88 »

Tient nous au courant, que je puisse savoir quand je peut présenter t'on super boulot à mes patrons.

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Bonjour,

Normalement, voici la solution :

Dans le fichier inth_maj.inc.php

Remplacer

Code : Tout sélectionner

 	var objet=window.opener.document.getElementById("codecocl");
	var codecocl=objet.value;
	objet.innerHTML="";
	<?PHP
	foreach ($tab_cocl as $key=>$value)
	{
		echo 'option = document.createElement("option");';
		echo 'option.setAttribute("value", "'.$key.'");';
		echo 'option.innerHTML = "'.$value.'";';
		echo 'objet.appendChild(option);';
	}
	?>
Par

Code : Tout sélectionner

	var objet=window.opener.document.getElementById("codecocl");
	var codecocl=objet.value;
	objet.innerHTML="";
	<?PHP
	foreach ($tab_cocl as $key=>$value)
	{
	?>
		option = window.opener.document.createElement("option");
		option.text = "<?PHP echo $value; ?>";
		option.value = "<?PHP echo $key; ?>";
		if (!document.all)
		{
			before= objet.options[1];
		}
		else
		{
		  before=1;
		}
		objet.add(option,before);
	<?PHP
	}
	?>
J'ai fait les vérifs sous IE7 et FF3, et ça fonctionne.

Bonne journée
Gestionnaire du projet SMI

andromede88
Membre
Messages : 24
Enregistré le : ven. févr. 27, 2009 11:57 am

Message par andromede88 »

T'a manip fonctionne niquel.

Encore bravo pour ta réactiviter.

feracheval
Membre
Messages : 77
Enregistré le : dim. févr. 15, 2009 10:40 pm

Message par feracheval »

:D super c ok pour moi aussi et bravo pour ta rapidité de solution, ca rassure.

Encore un petit bug, quand tu saisie une facture dans l'intervention et que tu rentre un montant HT et que tu clique sur modifier ou créer le script calcule à l'enver la TVA...
Il passe le montant ht tapé dans le montant ttc et recalcule le ht - la tva.

J'espere que j'ai été clair :wink: :?

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Je n'ai rien compris du tout... :shock:

On peut avoir le problème "clic par clic", "pas à pas", "écran par écran" ? :wink:

Merci


PS : Merci de ne pas "empiler" les fils et d'en ouvrir un autre à chaque fois. Cela facilitera le suivi et permettra d'améliorer les recherches des abonnés au forum
Gestionnaire du projet SMI

feracheval
Membre
Messages : 77
Enregistré le : dim. févr. 15, 2009 10:40 pm

Message par feracheval »

au départ je rentre une valeur ht de 1000 euros et à l'arrivée apres validation j'ai ca :

Total HT : 836.12€
TVA : 163.88€
Total TTC : 1000.00€
Acompte :
Net à payer : 1000.00€ TTC

le contraire de ce que je voulais :D

Répondre