Problème mot de passe

Vous avez détecté un bug ? Signalez-le ici.
Aloha
Membre
Messages : 52
Enregistré le : jeu. oct. 16, 2008 3:01 pm

Problème mot de passe

Message par Aloha »

Bonjour,

J'ai un un gros problème avec les comptes clients : aucun client ne peut se loger (il dit : Mauvais codes de connexion) et la demande de renouvellement de mot de passe ne fonctionne pas : Problème code utilisateur et/ou email - Mauvais code de validation.

Même en reinitialisant le mot de passe, ça ne fonctionne pas...

Je suis certain de ne pas me tromper dans les saisis.

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Bonjour,

Pour un code en particulier, au regard de l'autre message pour la liste emailing avec compte multiples, il se pourrait "fort bien" que les clients soient doublés dans la base.

Il faudrait vérifier les tables smi_cli et smi_pw.

Merci
Gestionnaire du projet SMI

Aloha
Membre
Messages : 52
Enregistré le : jeu. oct. 16, 2008 3:01 pm

Message par Aloha »

Re Galawa,

Smi me dit que tout va bien, phpMyAdmin aussi.

La table smi_cli ne comporte pas de clients en double... :shock:

Supprimer et recréer complètement la base ?

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Et la table smi_pw ???
Gestionnaire du projet SMI

Aloha
Membre
Messages : 52
Enregistré le : jeu. oct. 16, 2008 3:01 pm

Message par Aloha »

Non plus...

Mais du coup j'ai complêtement recréer la base en ayant pris soin d'exporter les clients puis en les réimportant après la création.

Cette fois, l'identification des clients fonctionne.

Pour l'emailing client, le problème des clients qui apparaissent 5 fois est résolu, par contre l'envoi ne fonctionne toujours pas :

Warning: set_time_limit() has been disabled for security reasons in /home/www/97eb275a9d5d9542d7cc2be4c9c931d1/web/smi/inc/email_maj.inc.php on line 138

Warning: Invalid argument supplied for foreach() in /home/www/97eb275a9d5d9542d7cc2be4c9c931d1/web/smi/inc/mail.inc.php on line 1582

Merci

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Bonjour,

Pour le premier message, cela vient du serveur sur lequel la fonction set_time_limit a été désactivée.

C'est assez gênant dans ce cas particulier d'emailing, car nous la mettons à zéro pour ne pas provoquer de plantage du script si le temps d'exécution est trop long.

Sinon, il suffit de commenter la ligne en question avec un "//" au début de celle-ci...mais à vos "risques et périls".

Pour le second message, j'ai pas de problème sur notre serveur de tests.

Il faudrait insérer, dans le fichier mail.inc.php, ligne 1582 (avant le $i=0) la ligne suivante :

Code : Tout sélectionner

print_r($tab_dest);echo"<br>";
Et dire ce que ça donne.

Merci
Gestionnaire du projet SMI

Aloha
Membre
Messages : 52
Enregistré le : jeu. oct. 16, 2008 3:01 pm

Message par Aloha »

Bonjour,

Ca ne fonctionne toujours pas, j'ai exactement les mêmes messages d'erreurs (normal pour le premier, je n'ai pas tenter les modifs pour l'instant.)

Merci

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Il n'y a pas de tableau affiché en haut de l'écran avec la modif print_r ??????
Gestionnaire du projet SMI

Aloha
Membre
Messages : 52
Enregistré le : jeu. oct. 16, 2008 3:01 pm

Message par Aloha »

En fait, les mails passent avec l'espace d'un instant toujours le premier message qui s'affiche (Warning: set_time_limit() has been disabled for security reasons in /home/www/.../web/smi/inc/email_maj.inc.php on line 138 ) mais cette fois les adresses mail s'affichent juste après l'erreur (Array ([mail@domaine.fr] => Nom Client).

Les mails arrivent bien sur les boites.

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

Bonsoir,

La liste array des emails est ok ?

Merci
Gestionnaire du projet SMI

Aloha
Membre
Messages : 52
Enregistré le : jeu. oct. 16, 2008 3:01 pm

Message par Aloha »

Oui, les mails sont bon.

Donc le message set_time_limit() on "s'en fou" ?

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

J'ai donné la solution plus haut...Mais c'est un problème de serveur, pas de SMI
Gestionnaire du projet SMI

Aloha
Membre
Messages : 52
Enregistré le : jeu. oct. 16, 2008 3:01 pm

Message par Aloha »

J'avais bien compris ! :)

Mais du moment que les mails passent quand même, on peut ne pas y prêter attention ou ça va poser problème à un moment ?

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Message par Galawa »

"On" fait comme on veut, mais un message d'erreur c'est moche, non ? :wink:
Gestionnaire du projet SMI

Aloha
Membre
Messages : 52
Enregistré le : jeu. oct. 16, 2008 3:01 pm

Message par Aloha »

Galawa a écrit :un message d'erreur c'est moche, non ? :wink:
Tout à fait d'accord avec vous !! :wink:

Qu'est ce que je fait alors, je mets en commentaire la fameuse ligne ? Et en fait, quels sont les risques ?

Répondre