Problèmes divers

Installation, utilisation, paramétrage de SMI sous Windows

Problèmes divers

Messagepar Alma » Mar Août 04, 2015 11:32 pm

Bonjour,

Premièrement je voulais vous féliciter et vous remercier pour le développement de SMI, un outil pratique qui répondra bien à mes besoins, j'en suis sur.
Même si, à mon sens, les connaissances nécessaires à l'installation et au paramétrage de SMI ne sont pas en adéquation avec le publique intéressé/visé. Je connais beaucoup d’artisans et auto entrepreneurs pour qui ce logiciel serait intéressant, mais qui ne possède pas les compétences ni le temps pour le faire fonctionner.


Je rencontre un problème d'utilisation, lorsque j'ajoute un nouveau client, je peux choisir le pays mais pas de département ni de ville. Alors que ces choix sont disponibles si je crée un technicien, une agence ou un sous traitant. Je précise que je me connecte en administrateur sous SMI.
[EDIT] Ce problème est résolu, le paramètre de la zone de chalandise n'avait pas été correctement validé lors de la création de l'agence gestionnaire.

Est il possible, dans le formulaire de création de client, des pré-remplir certains champs, comme le pays par exemple ? Pour ne pas à avoir à re-saisir à chaque fois les mêmes informations.

J'ai fait la mise à jour en version 1.0.2, lorsque je lance SMI, c'est bien ce numéro de version qu'il m'affiche mais lors du passage de la 1.0.1 à la 1.0.2, PHPMyAdmin m'a retourné une erreur :
"Erreur dans le traitement de la requête
Code de l'erreur :200
Texte de l'erreur : OK"
Tout à l'air de fonctionner, mais y a t il des conséquences ?

Merci pour votre aide.

Configuration :
Windows 8.1 x64
XAMPP v3.2.1
SMI 1.0.2
Alma
Nouveau membre
 
Messages: 2
Enregistré le: Ven Juil 31, 2015 9:44 pm

Re: Problèmes divers

Messagepar Galawa » Ven Août 07, 2015 8:30 am

Bonjour,

Merci pour vos encouragements.

Concernant le pré-remplissage, pourquoi pas.

Mais cela obligera à remodifier la saisie si le client n'est pas dans le pays par défaut du siège.

Peut-être un sondage....

Pour votre erreur, vous l'avez obtenue en faisant quoi exactement ?

Merci.

Galawa
Gestionnaire du projet SMI
Galawa
Site Admin
 
Messages: 1362
Enregistré le: Jeu Fév 22, 2007 11:26 am

Re: Problèmes divers

Messagepar Alma » Mer Août 12, 2015 5:37 pm

Bonjour,

Pour le pré remplissage je pensais plus à modifier le fichier php concerné. Au lieu que la valeur par défaut soit vide pré remplir le champ "manuellement" dans le code. Si c'est possible et si oui, je ne sais pas où...

J'obtiens l'erreur en déplaçant le fichier de mise à jour en version 1.0.2 vers la console de requêtes SQL de PHPMyAdmin.
J'ai copié uniquement le code contenu dans le fichier de mise à jour, et je l'ai collé dans la console de requêtes et la c'est passé correctement. Donc ce problème est lui aussi résolu.

Par contre le pré remplissage me ferait vraiment gagner du temps, j'habite en Martinique, tous mes clients sont sur l’île, donc si je pouvais modifier le formulaire de création client, afin de modifier le pays par défaut, ça serait so good.

Merci,
Alma
Nouveau membre
 
Messages: 2
Enregistré le: Ven Juil 31, 2015 9:44 pm

Re: Problèmes divers

Messagepar Galawa » Mar Août 18, 2015 9:46 am

Bonjour,

Je propose un paramétrage permettant de dire à SMI de choisir, en création de client, si le pays du client doit être le pays de l'agence (dans le cas où c'est un technicien ou une agence qui crée), le pays du centre de gestion, ou de laisser le choix.

Nous envisageons également un choix pour la devise par défaut.

Merci.

Galawa
Gestionnaire du projet SMI
Galawa
Site Admin
 
Messages: 1362
Enregistré le: Jeu Fév 22, 2007 11:26 am


Retour vers SMI sous Windows

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron