Problème au niveau de l'authentification

Installation, utilisation, paramétrage de SMI sous Windows
Répondre
DA Micro Services
Nouveau membre
Messages : 1
Enregistré le : mer. janv. 22, 2014 2:32 pm

Problème au niveau de l'authentification

Message par DA Micro Services »

Bonjour,

Je viens d'installer SMI, installation pas de soucis pas d'erreur. Par contre, lors de l'authentification il me dit toujours erreur 404 page introuvable. Dans la barre d'adresse www.damicroservices.fr/smi/admin/index.php. La page se trouve bien sûr le serveur.

Serveur 1and1

Merci d'avance

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème au niveau de l'authentification

Message par Galawa »

Bonjour,

Je viens de cliquer sur le lien que vous donnez : pas mal d'erreurs SQL...

Il faut donc :

1.Vérifier que vous avez bien les bons paramètres de connexion dans le fichier prm.inc.php (sections "Nom de la base MySQL" et "Constantes des bases MySQL")
2.Vérifier que vous avez bien défini le bon répertoire pour l'application (section "Répertoire de l'application")

A noter, pour 1&1, qu'il faut un .htaccess dans la racine du site, avec les instructions suivantes :

Code : Tout sélectionner

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
Un dernière chose : vous utilisez quelle version de SMI ?

Bonne fin de journée.

Galawa
Gestionnaire du projet SMI

TAD
Membre
Messages : 13
Enregistré le : mar. mars 27, 2012 8:40 am

Re: Problème au niveau de l'authentification

Message par TAD »

DA Micro Services a écrit :Bonjour,
Je viens d'installer SMI, installation pas de soucis pas d'erreur. Par contre, lors de l'authentification il me dit toujours erreur 404 page introuvable. Dans la barre d'adresse.
La page se trouve bien sûr le serveur.
Bonsoir Galawa je rencontre le même problème sur mon serveur install Ok avec réception Email mais impossible de me connecté
- srv linux
- sms v0.9.9z
- srv webhostingpad

lien ver la page : http://itsav.tadit-services.com/

stp besoin d'une solution car sur Windows avec Xampp j'ai du laissé tombé faute de réponse sur le forum pour m'aider à résoudre les pb signalés

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème au niveau de l'authentification

Message par Galawa »

Bonjour,

A priori, vous travaillez en sous-domaine...

Quelques tests :

1.Vérifiez la valeur de $root renvoyée par votre serveur
Pour ce modifiez le code suivant (fichier config.inc.php) :

Code : Tout sélectionner

$root = $_SERVER['DOCUMENT_ROOT'] . "/"; // Racine réelle du site
en

Code : Tout sélectionner

$root = $_SERVER['DOCUMENT_ROOT'] . "/"; // Racine réelle du site
echo $root."<br>";
Au besoin, forcez le chemin en valeur absolue

ATTENTION : Dès que vous avez la valeur, revenez à l'ancien code !

2.Vous pouvez aussi modifier les valeurs de $urf_gfc et $url_svg en valeur absolue (fichier prm.inc.php)

3.Testez l'accès à SMI en entrant http://adresse du site parent/chemin où est stocké SMI

A noter qu'il faut impérativement que SMI soit installé dans un sous-dossier de la racine du site (c'est indiqué dans la procédure d'installation).

Merci.

Galawa
Gestionnaire du projet SMI

TAD
Membre
Messages : 13
Enregistré le : mar. mars 27, 2012 8:40 am

Re: Problème au niveau de l'authentification

Message par TAD »

Bjr Galawa
en entrant mon adresse de cette façon: taxxxxxxxxxx.com/smi je me conecte directement à SMI, pourtant j'ai crée un sous domaine à cet adresse: smi.taxxxxxxxxxx.com juste pour l'installation de SMI ce qui se passe sans problement mais à la connexion avec l'adresse du sous domaine sa me renvoi ceci:
Not Found

The requested URL /SMI/admin/index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

précédement tu as proposé ceci:
Galawa a écrit :A priori, vous travaillez en sous-domaine...
Au besoin, forcez le chemin en valeur absolue

2.Vous pouvez aussi modifier les valeurs de $urf_gfc et $url_svg en valeur absolue (fichier prm.inc.php)
SMI est bien dans le dossier public_html de mon serveur web
stp coe résoudre se probleme

Répondre