Problème création ville

Installation, utilisation, paramétrage de SMI sous Windows
Répondre
pak2015
Nouveau membre
Messages : 9
Enregistré le : mar. août 30, 2011 2:52 pm

Problème création ville

Message par pak2015 »

Bonjour,

Sur un SMI tout neuf, je souhaite créer une nouvelle VILLE.

Tout d'abord dans la liste des départements, il me mets juste "INCONNU" et "Faites votre choix" = je n'ai donc pas la liste pour attribuer le département à la ville => je laisse donc en "Inconnu"

Une fois la page validé, il affiche la page "Fiche ajoutée " puis lors de l'actualisation automatique il indique en haut ce message d'erreur:

"Warning: include_once(../lng/FR.inc.php) [function.include-once]: failed to open stream: No such file or directory in /homez.227/sengit/www/smi/admin/villes_lst.php on line 28

Warning: include_once() [function.include]: Failed opening '../lng/FR.inc.php' for inclusion (include_path='.:/usr/local/lib/php') in /homez.227/sengit/www/smi/admin/villes_lst.php on line 28"

Je suis obligé de quitter le site et me reconnecter pour accéder de nouveau à SMI, mais bien entendu il n'a pas créé la ville.

Avez-vous une idée du problème ?

Merci de votre aide.

pak2015
Nouveau membre
Messages : 9
Enregistré le : mar. août 30, 2011 2:52 pm

Re: Problème création ville

Message par pak2015 »

Alors après avoir regarder dans Mysql, je me suis aperçu que le département de la ville créée était marqué en "-1".
Ceci est certainement dût au fait que je ne pouvais sélectionner de département dans le formulaire de création de la ville.

Mais pourquoi ? je ne sais pas.

J'ai donc modifié la donnée dans la base par "92", et dans la création du centre de gestion, j'ai bien maintenant le nom de la ville après avoir sélectionné le département.

Merci de votre retour pour résoudre ce problème.

oxedgar
Membre
Messages : 87
Enregistré le : dim. juil. 27, 2008 8:38 am
Localisation : Suisse

Re: Problème création ville

Message par oxedgar »

Bonjour, Pak2015,

J'ai rencontré le même problème...

J'ai réussi a créer une ville test mais j'ai du modifier un petit truc sur les fichiers dans le serveur...

En effet, notre erreur indique que le fichier ../lng/FR.inc.php est introuvable dans la première erreur puis qu'il ne peut l'inclure dans la deuxième!
Malheureusement il a un peut raison!!! :roll: :lol: :roll:
Si votre serveur est sur linux / Unix comme moi, alors le fichier recherché n'existe pas car le nom des fichiers est sensible a la casse dans un environnement linux au contraire de Windows. (Cela reste a vérifier si quelqu'un peut confirmer qu'il ne rencontre aucun problème avec l'ajout de villes sur un serveur MS Windows)
Si vous copiez le fichier ../lng/fr.inc.php et que vous le collez dans le dossier ../lng/ avec le nom FR.inc.php alors, vous n'aurez plus d'erreur d'enregistrement.
La ville est bien créée dans la base de données et tout va bien :D

Malheureusement, il reste un problème dans mon cas je ne sais pas pour vous mais lorsque je vais en mode Administrateur dans Administration-> Géographie->villes, il n'y a tout simplement aucune ville alors que j'en ai 43747 dans la base de données!?! et vous?
http://www.APCorp.ch
Solutions Open Source pour entreprises
Création de sites internet professionnels et Lowcost

pak2015
Nouveau membre
Messages : 9
Enregistré le : mar. août 30, 2011 2:52 pm

Re: Problème création ville

Message par pak2015 »

Bonjour Oxedgar,

Merci pour le tuyau.

Concernant l'affichage des villes, je me suis fais la même remarque mais j'ai compris après qu'il fallait faire une recherche de ville pour qu'elles s'affichent.
Vu le nombre de ville, je pense que c'est pour alléger la page (ce qui est une très bonne idée)..

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème création ville

Message par Galawa »

Bonsoir,

Je viens de comprendre ce qui se passait.

Cela provient de la routine AJAX qui appelle les départements en fonction du pays.

C'est corrigé et sera ok pour la prochaine version.

Bonne soirée

Galawa
Gestionnaire du projet SMI

Répondre