page blanche après installation

Installation, utilisation, paramétrage de SMI sous Gnu/Linux

page blanche après installation

Messagepar bensz » Mer Août 24, 2016 3:42 pm

Bonjour,
Je voudrai installer SMI sur un serveur Debian/Apache/php/Mariadb.
Tout s'est passé correctement ( j'ai juste oublié de mettre le fichier prm... dans le dossier inc, mais à la première connexion j'ai un rappel). Tout étant à priori OK, j'appelle la page d’accueil, et là, page blanche. En fouillant un peu dans le forum, il apparaît que l'utilisateur admin ne se crée pas dans la base ce qui me fait penser à un problème d'accès. Mais tous les paramètres sont bon pour l'accès à la base. J'ai bien indiqué localhost comme hôte. De plus rien n’apparaît dans les logs.

une idée?
Merci
Benoit
bensz
Nouveau membre
 
Messages: 4
Enregistré le: Mer Août 24, 2016 7:22 am

Re: page blanche après installation

Messagepar Galawa » Sam Août 27, 2016 1:43 pm

Bonjour,

Vérifiez votre fichier prm.inc.php

Pour vous aider :

http://smi.no-ip.org/phpBB3/viewtopic.php?t=765

Bon week-end

Galawa
Gestionnaire du projet SMI
Galawa
Site Admin
 
Messages: 1354
Enregistré le: Jeu Fév 22, 2007 11:26 am

Re: page blanche après installation

Messagepar bensz » Lun Août 29, 2016 10:47 am

Bonjour,
Merci pour le lien, mais j'en avais déjà consulté plusieurs parlant de ce sujet. A priori mon fichier est bon. D'autre part, la connexion à la base est bonne. J'arrive à ma connecter avec le user et le mdp du fichier. J'ai dû rater une ligne, mais je ne vois pas laquelle. Où puis-je trouver un message d'erreur?

Merci
Benoit
bensz
Nouveau membre
 
Messages: 4
Enregistré le: Mer Août 24, 2016 7:22 am

Re: page blanche après installation

Messagepar bensz » Lun Août 29, 2016 11:13 am

Pour info, un extrait de mon fichier prm:

/**************************************************/
/** Répertoire de l'application **/
/**************************************************/

define('REP', 'smi'); // Répertoire de l'application

$rep_appli = $racine_web . '/' . REP; // Chemin web absolu vers l'application

/*******************************************/
/** Nom de la base MySQL **/
/*******************************************/

define('DBNAME', 'smi'); // Nom de la base de données
define('PREFIXE', 'smi'); // Préfixe des noms des tables

/*************************************************************/
/** Constantes des bases MySQL **/
/*************************************************************/

// login/mot de passe Administrateur par défaut (créé la 1ère fois)

$admin_code = 'root'; // Code 'Administrateur'
$admin_mdp = 'xxxx'; // Mot de passe 'Administrateur'


// Constantes de connexion à la base MySQL

define('DBUSER', 'smi'); // Utilisateur MySQL
define('DBPASS', 'xxxx'); // Mot de Passe pour MySQL
define('DBHOST', 'localhost'); // Adresse IP du serveur MySQL


/****************************************************/
/** Variables des téléchargements **/
/****************************************************/

/*************************************************************/
/** Constantes et variables pour la gestion des icônes **/
/** pour les statuts et des logos pour les agences, **/
/** et les applications complémentaires **/
/*************************************************************/
// Constantes & Variables des répertoires pour les fichiers internes et téléchargés, et les sauvegardes

$url_gfc = '/var/www/datas/smi/telechgt/fictec'; // Chemin REEL complet pour la gestion des fichiers techniques
//$url_gfc = '/srv/www/datas/smi/telechgt/fictec'; // Chemin REEL complet pour la gestion des fichiers techniques
$url_tfc = '../../datas/smi/telechgt/fictec/'; // Chemin REEL depuis la racine pour le téléchargement des
// fichiers techniques
$url_svg = '/var/www/datas/smi/svg/'; // Chemin REEL vers le répertoire des sauvegardes
//$url_svg = '/srv/www/datas/smi/svg/';


Merci
Benoit
bensz
Nouveau membre
 
Messages: 4
Enregistré le: Mer Août 24, 2016 7:22 am

Re: page blanche après installation

Messagepar Galawa » Lun Août 29, 2016 12:15 pm

Bonjour,

Il va falloir procéder par séquence.

Insérez des echo 'ok<br>"; à intervalles réguliers, dans le fichier index.php.

Si ok s'affiche, c'est que l'étape est passée.

Sinon, il faut voir où ca "coince"...avant le echo

Merci.

Galawa
Gestionnaire du projet SMI
Galawa
Site Admin
 
Messages: 1354
Enregistré le: Jeu Fév 22, 2007 11:26 am

Re: page blanche après installation

Messagepar bensz » Lun Août 29, 2016 12:47 pm

Bonjour,
En fait mon index bloque ligne 41-42
sur
if ($messerr == '') {
include_once('inc/config.inc.php');

après, rien n'est lu.
Sachant que ce fichier existe qu'il a les droits rw pour l'utilisateur et que je ne l'ai pas modifié.


Merci
Benoit
bensz
Nouveau membre
 
Messages: 4
Enregistré le: Mer Août 24, 2016 7:22 am

Re: page blanche après installation

Messagepar Galawa » Jeu Sep 01, 2016 1:25 pm

Bonjour,

Dans ce cas, mettez des pointeurs dans le fichier config.inc.php

Merci.

Galawa
Gestionnaire du projet SMI
Galawa
Site Admin
 
Messages: 1354
Enregistré le: Jeu Fév 22, 2007 11:26 am


Retour vers SMI sous Gnu/Linux

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité

cron