Problème lors de l'installation

Installation, utilisation, paramétrage de SMI sous Gnu/Linux
Verrouillé
macabreyh
Nouveau membre
Messages : 7
Enregistré le : lun. févr. 02, 2015 8:31 pm

Problème lors de l'installation

Message par macabreyh »

Madame, Monsieur,

J'ai un problème lors de l'installation du SMI 1.0.0.
Je suis la procédure décrite sur votre site Internet et il me sort des erreurs.

Voici le lien :
http://repair.sinmedia.ch/

Voici l'erreur :
Warning: Table 'admin_2015_SMI.admin_2015_SMI_log' doesn't exist in /home/httpd/vhosts/sinmedia.ch/repair.sinmedia.ch/classes/ezSQL/mysqli/ez_sql_mysqli.php on line 266 Warning: Table 'admin_2015_SMI.admin_2015_SMI_pw' doesn't exist in /home/httpd/vhosts/sinmedia.ch/repair.sinmedia.ch/classes/ezSQL/mysqli/ez_sql_mysqli.php on line 266 Warning: Table 'admin_2015_SMI.admin_2015_SMI_pw' doesn't exist in /home/httpd/vhosts/sinmedia.ch/repair.sinmedia.ch/classes/ezSQL/mysqli/ez_sql_mysqli.php on line 266

Lors de l'installation, comment se crée les tables dans la base de donnée ?
Je fais une faute ?

D'avance, je vous remercie et vous souhaite une excellente journée.

Avec mes cordiales salutations.
Hervé Macabrey

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème lors de l'installation

Message par Galawa »

Bonsoir,

SMI a besoin d'utiliser le même radical de nom de table que le nom de la base.

Ainsi, par exemple, si votre base s'appelle admin_2015_SMI, il faut que les tables s'appellent admin_2015_SMI_...

Si ce n'est pas le cas, renommez les noms des tables, qui sont, par défaut en smi_, en admin_2015_SMI_

Bonne soirée.

Galawa
Gestionnaire du projet SMI

macabreyh
Nouveau membre
Messages : 7
Enregistré le : lun. févr. 02, 2015 8:31 pm

Re: Problème lors de l'installation

Message par macabreyh »

Bonsoir,

Je vous remercie de votre réponse.
Cependant, je n'ai pas de table dans la base de donnée.

Lors de votre suivi de procédure, je ne vois pas comment et quoi ajouter comme table dans ma base.

Il y a pas une installation automatique des tables ? C'est donc une première installation.

Dans votre dossier install, j'ai que install.txt... c'est normal ?

Merci d'avance, de votre réponse et vous souhaite une excellente soirée.

Avec mes cordiales salutations.
Hervé Macabrey

Galawa
Site Admin
Messages : 1364
Enregistré le : jeu. févr. 22, 2007 11:26 am
Contact :

Re: Problème lors de l'installation

Message par Galawa »

Bonsoir,

Dans le dossier install, il y a un dossier sql.

Vous y trouverez le fichier smi_1.0.0.sql.

C'est dans ce fichier qu'il faut renommer les préfixes smi_ en admin_2015_SMI_ (dans votre cas précis).

Ensuite, il faudra le charger sous un gestion comme phpmyadmin et l'exécuter.

Ensuite, vérifiez vos paramètres dans prm.inc.php (notamment ceux d'accès à la base MySQL) et vous pourrez démarrer SMI...après avoir supprimé le dossier install de votre serveur web.

Bonne soirée.

Galawa
Gestionnaire du projet SMI

macabreyh
Nouveau membre
Messages : 7
Enregistré le : lun. févr. 02, 2015 8:31 pm

Re: Problème lors de l'installation

Message par macabreyh »

Monsieur,

Je vous remercie, c'est parfait :)

Merci et excellente journée à vous.

Verrouillé